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SAFETY PRECAUTIONS
(Always read these instructions before using this product.)

Before using this product, thoroughly read this manual and the relevant manuals introduced in this manual 
and pay careful attention to safety and handle the products properly.
The precautions given in this manual are concerned with this product. For the safety precautions of the 
system, refer to the User's Manual for each controller.
In this manual, the safety precautions are ranked as 'DANGER' and 'CAUTION'.

Note that the  CAUTION level may lead to serious consequences according to the circumstances.
Always follow the precautions of both levels because they are important for personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Instructions]

[Startup/Maintenance Instructions]

DANGER
● When data change, program change, or status control is performed from a personal computer to a running controller, 

create an interlock circuit outside the programmable controller to ensure that the whole system always operates safely.
Furthermore, for the online operations performed from a personal computer to a controller, the corrective actions against a 
communication error due to such as a cable connection fault should be predetermined as a system.

CAUTION
● The online operations performed from a personal computer to a running controller (Program change, operating status 

change such as RUN-STOP switching, and remote control operation) have to be executed after the manual has been 
carefully read and the safety has been ensured.
When changing a program while a controller is RUN, it may cause a program corruption in some operating conditions. 
Fully understand the precautions described in the manuals and Help function of each controller before use.

DANGER

CAUTION

Indicates that incorrect handling may cause hazardous conditions, 

resulting in death or severe injury.

Indicates that incorrect handling may cause hazardous conditions, 

resulting in miner or moderate injury or property damage.
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REVISIONS
The manual number is written at the bottom left of the back cover.

Japanese Manual Version BCN-P5705-A

© 2008 MITSUBISHI ELECTRIC CORPORATION

Print date Manual number Revision

Jul., 2008 BCN-P5717-A First edition

This manual confers no industrial property rights or any rights of any other kind, nor does it confer any patent licenses.
Mitsubishi Electric Corporation cannot be held responsible for any problems involving industrial property rights which may occur 
as a result of using the contents noted in this manual.
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INTRODUCTION

Thank you for purchasing the Mitsubishi integrated FA software, MELSOFT series.
Before using the product, thoroughly read this manual to develop full familiarity with the functions and performance 
to ensure correct use.
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■ MANUALS

The manuals related to this product are shown below.
Refer to the following tables when ordering required manuals.

Related manuals
1) MELSOFT Navigator

For details of operations, refer to the HELP function of MELSOFT Navigator.

2) GX Works2

3) GT Designer2

Manual name Manual number 
(Model code)

GX Works2 Version1 Operating Manual (Common)
Explains the system configuration of GX Works2 and the functions common to a Simple project and 
Structured project such as parameter setting, operation method for the online function.

(Sold separately)

SH-080779
(13JU63)

GX Works2 Version1 Operating Manual (Simple Project)
Explains operation methods such as creating and monitoring programs in Simple project of GX Works2.

(Sold separately)
SH-080780
(13JU64)

GX Works2 Version1 Operating Manual (Structured Project)
Explains operation methods such as creating and monitoring programs in Structured project of GX 
Works2.

(Sold separately)

SH-080781
(13JU65)

GX Works2 Beginner's Manual (Simple Project)
Explains fundamental operation methods such as creating, editing, and monitoring programs in Simple 
project for users inexperienced with GX Works2.

(Sold separately)

SH-080787
(13JZ22)

GX Works2 Beginner's Manual (Structured Project)
Explains fundamental operation methods such as creating, editing, and monitoring programs in 
Structured project for users inexperienced with GX Works2.

(Sold separately)

SH-080788
(13JZ23)

Manual name Manual number 
(Model code)

GT Designer2 Version2 Basic Operation/Data Transfer Manual (For GOT 1000 Series)
Explains common settings, object function specifications, setting methods, and arranging methods of GT 
Designer2.

(Sold separately)

SH-080529ENG
(1D7M24)

GT Designer2 Version2 Screen Design Manual (For GOT 1000 Series) (1/3, 2/3, 3/3)
Explains the system configuration, screen configuration, basic operations for dialog boxes, methods 
such as creating new project and transferring data to GOT, and convenient screen editing operations of 
GT Designer2.

(Sold separately)

SH-080530ENG
(1D7M25)

GT Converter2 Version2 Operating Manual
Explains the specifications and operation methods of GT Converter2.

(Sold separately)

SH-080533ENG
(1D7M27)

GT Simulator2 Version2 Operating Manual
Explains the system configuration, screen configuration, and operation methods of GT Simulator2 used 
in GOT1000 series (GT15/GT11) and GOT-A900 series.

(Sold separately)

SH-080546ENG
(1D7M34)

GT SoftGOT1000 Version2 Operating Manual
Explains the system configuration, screen configuration, and operation methods of monitoring software 
GT SoftGOT1000.

(Sold separately)

SH-080602ENG
(1D7M48)

GT Works2 Operating Manual (MELSOFT iQ Works)
Explains the operation methods and precautions of GT Designer2, GT Simulator2, and GT SoftGOT1000 
that are used in MELSOFT iQ Works.

(Sold separately)

SH-080791ENG
(1D7M89)
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4) MT Developer2
Refer to the HELP function of MT Developer2.

5) Motion Controllers

Manual name Manual number 
(Model code)

Q173HCPU/Q172HCPU Motion Controller (SV13/SV22) Programming Manual (Motion SFC)
Explains the functions, programming, debugging, and error codes of Motion SFC.
(Included in SV13/SV22)

IB-0300112
(1XB912)

Q173DCPU/Q172DCPU Motion Controller (SV13/SV22) Programming Manual (Motion SFC)
Explains the functions, programming, debugging, and error codes of Motion SFC.
(Included in SV13/SV22)

IB-0300135
(1XB929)

The Operating Manual is included in the CD-ROM with the software package.
Manuals in printed form are sold separately for single purchase. Order a manual by quoting the manual number 
(model code) listed in the table above.
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● Purpose of this manual
This manual explains the features and operations of iQ Platform compatible engineering environment 
MELSOFT iQ Works.

Manuals and the HELP function for reference are listed in the following table according to their 
purpose.
For information such as the contents and number of each manual, refer to the list of 'Related 
manuals'.

Purpose Manuals and HELP function for reference

Creating GX Works2 
projects

Basic 
operation

GX Works2 Version1 Operating Manual (Common)
GX Works2 Version1 Operating Manual (Simple Project)
GX Works2 Version1 Operating Manual (Structured Project)
GX Works2 Beginner's Manual (Simple Project)
GX Works2 Beginner's Manual (Structured Project)

Label setting

GX Works2 Version1 Operating Manual (Simple Project)
GX Works2 Version1 Operating Manual (Structured Project)
GX Works2 Beginner's Manual (Simple Project)
GX Works2 Beginner's Manual (Structured Project)

Creating MT Developer2 
projects

Operation HELP function of MT Developer2

Label setting HELP function of MT Developer2

Creating GT Designer2 
projects Operation GT Designer2 Version2 Screen Design Manual (For GOT 1000 Series)

GT Works2 Operating Manual (MELSOFT iQ Works)

Using label linkage function

GX Works2 Version1 Operating Manual (Simple Project)
GX Works2 Version1 Operating Manual (Structured Project)
GX Works2 Beginner's Manual (Simple Project)
GX Works2 Beginner's Manual (Structured Project)
HELP function of MT Developer2

Using program jump function Q173HCPU/Q172HCPU Motion Controller (SV13/SV22) Programming Manual (Motion SFC)
Q173DCPU/Q172DCPU Motion Controller (SV13/SV22) Programming Manual (Motion SFC)
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■ HOW TO READ THIS MANUAL

This section explains how to read this manual according to your purpose when using MELSOFT iQ 
Works.
Please use this manual with referring to the following descriptions.

1) To learn about the overview of MELSOFT iQ Works

 Chapter 1  OVERVIEW

Chapter 1 explains the features of MELSOFT iQ Works.

2) To learn about the screen configuration of MELSOFT iQ Works

 Chapter 2  SCREEN CONFIGURATION

Chapter 2 explains the screen configuration of MELSOFT Navigator.

3) To learn about the operating procedures of MELSOFT Navigator

 Chapter 3  CREATING WORKSPACES

Chapter 3 explains a sequence of the basic operation from start-up to creating and saving methods 
of workspaces and projects.

4) To learn about the label linkage function

 Chapter 4  USING LABEL LINKAGE FUNCTION

Chapter 4 explains the functions to utilize labels used in a project with other projects.

5) To learn about the program jump function

 Chapter 5  USING PROGRAM JUMP FUNCTION

Chapter 5 explains the function which can start motion SFC programs/servo programs, that are 
linked with motion controller programs, using the SFCS and SVST instructions of ladder programs.
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This explains notes requiring attention or useful functions relating to the information given on the 
same page.

● Symbols used in this manual
The following shows the symbols used in this manual with descriptions and examples.

No. Symbol Description Example

[       ] Menu name on a menu bar [File]

Toolbar icon

"        " Item name in a workspace "Base Painting Device"

"        " Item name in a screen "Open Startup Screen at Start"

Button on a screen

- Keyboard key Ctrl
A - 9



■ GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL

This manual uses the generic terms and abbreviations listed in the following table to discuss the 
software packages and programmable controller CPUs. Corresponding module models are also listed if 
needed.

Generic term and abbreviation Description

MELSOFT Navigator
Generic product name of the integrated development environment for the SWnDNC-
IQWK-E (iQ Platform compatible engineering environment MELSOFT iQ Works)
(n: version)

GX Works2
Generic product name for the SWnDNC-GXW2-E
(n: version) 
MELSOFT Navigator compatible GX Works2 is GX Works2 Version1.03D or later.

MT Developer2
Generic product name for the SWnDNC-MTW2-E
(n: version)
MELSOFT Navigator compatible MT Developer2 is MT Developer2 Version1.02C or later.

GT Designer2
Generic product name for the SWnD5C-GTD2-E
(n: version)
MELSOFT Navigator compatible GT Designer2 is GT Designer2 Version2.81K or later.

Controller Generic terms for programmable controller, motion controller, and GOT

Network Generic terms for CC-Link IE controller network, MELSECNET/H, Ethernet, and CC-Link

Personal computer Generic term for personal computers on which Windows® operates

GOT Generic term for Mitsubishi Graphic Operation Terminal GOT1000 series
A - 10  
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1 OVERVIEW
This chapter explains the features of MELSOFT iQ Works.
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1  OVERVIEW
iQ Works
1.1 MELSOFT iQ Works
MELSOFT iQ Works is an engineering software product including GX Works2, MT Developer2, and GT Designer2.

While sharing design information such as system designs and programming in the whole control system, the 
system designing efficiency and the programming efficiency are improved, therefore, this system is able to realize 
the total cost reduction.

This manual explains the system management method using MELSOFT Navigator.

To start MELSOFT Navigator and each engineering software product, select each item registered in the start menu 
by following the procedures shown below.
• MELSOFT Navigator : Select [MELSOFT Application] ⇒ [MELSOFT iQ Works] ⇒ [MELSOFT Navigator].
• GX Works2 : Select [MELSOFT Application] ⇒ [GX Works2] ⇒ [GX Works2].
• MT Developer2 : Select [MELSOFT Application] ⇒ [MT Works2] ⇒ [MT Developer2].
• GT Designer2 : Select [MELSOFT Application] ⇒ [GT Works2] ⇒ [GT Designer2].

MELSOFT iQ Works

GX Works2

(Programming software for

programmable controller)

MT Developer2

(Programming software for

motion controller)

MELSOFT Navigator

(System configuration tool)

Design information

data base

Share design 

information

among software products

GT Designer2

(Graphics software for GOT)
1 - 2  
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1.2 Features
1.2 Features
This section explains the features of MELSOFT iQ Works.

■ Improved project management efficiency

● Multiple project management using the workspace
Multiple project data (programmable controller projects, motion controller projects, and GOT 
projects) can be managed using the workspace.

Projects can be organized into the folder as a group by creating a folder in the workspace tree.

Both date created and date modified of each project can be confirmed with the project list.

GOT project

Motion controller project

Programmable controller 

project

Workspace tree

Programmable controller projectMotion controller project

Workspace

Folder

GOT project
1 - 3



1  OVERVIEW
iQ Works
● Activating each engineering function
Operations such as program editing can easily be performed by selecting a project in the 
workspace individually.

Edit project
1 - 4  
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1.2 Features
● Easy data handling with the archive and save function
By saving the workspace data or the project data as an archived file, the saved data can easily be 
transferred to other environment.

Development environment B

Development environment A

Save CAB files in a 

CD-ROM

Archive and save

Transfer the data to 

 other development 

 environment by handling  

media such as CD-ROMs.
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1  OVERVIEW
iQ Works
■ Improved programming efficiency

● Improvement of programming (drawing) efficiency by the label linkage function

Programming (drawing) efficiency is improved by defining and assigning global labels to devices of 
programmable controller projects and motion controller projects, and sharing them with multiple 
projects.
As the device assignment settings are changed in a batch, the graphics are not necessary to be 
changed.

For the label linkage function, refer to the following chapter.

 Chapter 4

Create graphics using global  

labels that are set in the above projects.

GX Works2

GX Works2 MT Developer2

Create programs using global labels  

that are set in the above projects.

MT Developer2

GT Designer2
1 - 6  
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1.2 Features
● Improvement of programmable controller programming efficiency by linking with motion controller 
programs

The motion controller program, which corresponds to the motion dedicated programmable 
controller instruction selected in the sequence program, can be activated by the simple mouse 
operation. This function significantly improves programming efficiency.

For the program jump function, refer to the following chapter.

 Chapter 5

Open a programmable  

controller project

The motion controller program corresponds 

to the selected motion dedicated programmable 

controller instruction is activated.
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1  OVERVIEW
iQ Works
MEMO
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2 SCREEN CONFIGURATION
This chapter explains the screen configuration of MELSOFT Navigator.
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2  SCREEN CONFIGURATION
iQ Works
2.1 Screen Configuration
The following explains the screen configuration.

Screen display

Display contents

Name Description

Title bar Displays a title of product name, workspace path, and active window.

Menu bar Displays items of the basic menu.

Toolbar Displays tool buttons for executing functions that are used frequently.

Workspace tree Displays the projects managed in a workspace in tree format.

Project list Displays a list of projects contained in the selected item.

Status bar Displays information about the selected workspace or project.

Project listWorkspace tree

Status bar

Toolbar

Menu bar

Title bar
2 - 2  
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3 CREATING WORKSPACES
This chapter explains the method for creating workspaces using MELSOFT Navigator.
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3  CREATING WORKSPACES
iQ Works
3.1 Procedure of MELSOFT Navigator from Start to End
This section explains the procedure of MELSOFT Navigator from start to end.

For folders and files of created workspaces and projects, do not use Explorer to change the file name or storage 
location.

Start MELSOFT Navigator

Start

Create a workspace

Create a folder

Create a project

Edit the created project

Save the created workspace

Archive and save the workspace or folder

Close the workspace

Exit MELSOFT Navigator

Complete

Edit the project
Utilize an existing project
3 - 2  



1 

O
V

E
R

VI
EW

2

S
C

R
E

E
N

 C
O

N
FI

G
U

-
R

AT
IO

N

3

C
R

EA
TI

N
G

 W
O

R
K

-
SP

A
C

ES

4

U
S

IN
G

 L
A

B
EL

 L
IN

K-
A

G
E 

FU
N

C
TI

O
N

5

U
S

IN
G

 P
R

O
G

R
A

M
 

JU
M

P
 F

U
N

C
TI

O
N

3.2 Starting MELSOFT Navigator
3.2 Starting MELSOFT Navigator
This section explains the method for starting MELSOFT Navigator.

1. Start MELSOFT Navigator from 
Windows [Start] menu.

2. MELSOFT Navigator is activated.

●Double clicking the  icon on the desktop can also start MELSOFT Navigator.

Select

Double click the MELSOFT 

Navigator icon.
3 - 3



3  CREATING WORKSPACES
iQ Works
3.3 Creating Workspaces
This section explains the method for creating a new workspace.

1. Select [File] ⇒ [New] ⇒ [Workspace] 
( ) in the menu bar to display the 
"Create New Workspace" dialog box.

2. Enter "Save Folder Path", "Workspace 
Name", and "Title" of the new workspace.

After entering the items, click the  
button.

Setting example
• Save Folder Path : C:\Documents and 

Settings\
Administrator\
My Documents

• Workspace Name: Sample_WS
• Title (option) : Sample data

3. The new workspace has been created.

Select
3 - 4  
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3.3 Creating Workspaces
● Opening existing workspaces
An existing workspace can be opened by the following procedure.

1. Select [File] ⇒ [Open Workspace] 
( ) in the menu bar to display the 
"Open Workspace" dialog box.

2. Select "Save Folder Path" and 
"Workspace" for the workspace to 
be opened.

After selecting the items, click the 
 button to open the workspace.

Setting example

• Save Folder Path : C:\Documents and 
Settings\
Administrator\
My Documents

• Workspace Name: Sample_WS

Select
3 - 5



3  CREATING WORKSPACES
iQ Works
  

Set a workspace name, folder name, and project name in the workspace tree according to the system 
configuration.
The followings are setting examples of workspace name, folder name, and project name.

• 1 CPU configuration
System configuration Workspace tree

 

• Multiple CPU configuration
System configuration Workspace tree

ABC Temperature Control Board

Model name: Q25HCPU 

Project name: Control MAIN

Model name: GOT1000 

Project name: Main panel

Model name: Q172DCPU 

Project name: Transfer Control

Model name: Q25HCPU 

Project name: ABC MAIN 

Model name: Q06UDHCPU 

Project name: Receive MAIN

Model name: GOT1000 

Project name: Receive Control Panel
Model name: GOT1000 

Project name: ABC Panel

Network

<Receiving> <        process>

ABC Manufacturing Device
3 - 6  
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3.4 Creating Folders
3.4 Creating Folders
This section explains the method for creating a new folder in the workspace tree.

1. Select [File] ⇒ [New] ⇒ [Folder] in the 
menu bar to create a new folder in the 
workspace tree.

2. Change the created folder name.

Select the folder, and select [File]   ⇒  
[Rename] in the menu bar.

Setting example
• Folder name: Sample Folder

3. The folder name has been changed.

Select
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3  CREATING WORKSPACES
iQ Works
3.5 Creating Projects
This section explains the method for creating project data (programmable controller projects, motion controller 
projects, and GOT projects).

3.5.1 Creating new projects

■ Programmable controller projects

This section explains the method for creating a new programmable controller project.

1. Select [File] ⇒ [New] ⇒ [GX Works2 
Project] in the menu bar to display the 
"Create New GX Works2 Project" 
dialog box.

2.  Set "Project Name", "Title", "Project 
Type", "PLC Series", "PLC Type", and 
"Language" for the new project.

After setting the items, click the   
button.

Setting example
• Project Name : GXW2_Pro1
• Title (option) : Sample data
• Project Type : Simple Project
• Use Labels : No
• PLC Series : QCPU (Q mode)
• PLC Type : Q06UDH
• Language : Ladder

(To the next page)

Select
3 - 8 3.5.1 Creating new projects
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3.5 Creating Projects
(From the previous page)

3. The new project has been created.

After creating the new project, double click it 
in the workspace tree.

4. The programmable controller project is 
activated.

For the method for editing programmable 
controller projects, refer to the following 
manuals.

• GX Works2 Version1 Operating 
Manual (Common)

• GX Works2 Version1 Operating 
Manual (Simple Project)

• GX Works2 Version1 Operating 
Manual (Structured Project)

• GX Works2 Beginner's Manual 
(Simple Project)

• GX Works2 Beginner's Manual 
(Structured Project)

Double click
3.5.1 Creating new projects 3 - 9
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■ Motion controller projects

This section explains the method for creating a new motion controller project.

1. Select [File] ⇒ [New] ⇒ [MT 
Developer2 Project] in the menu bar to 
display the "Create New MT 
Developer2 Project" dialog box.

2. Set "Project Name", "CPU Type", and 
"OS Type" for the new project.

After setting the items, click the   
button. 

Setting example
• Project Name : MTD2_Pro1
• Title (option) : Sample data
• CPU Type : Q173H
• OS Type : SW6-SV13QK

3. The new project has been created.

After creating the new project, double click 
it in the workspace tree.

4. The motion controller project is 
activated.

For the method for editing motion controller 
projects, refer to the HELP function of MT 
Developer2.

Select

Double click
3 - 10 3.5.1 Creating new projects
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3.5 Creating Projects
■ GOT projects

This section explains the method for creating a new GOT project.

1. Select [File] ⇒ [New] ⇒ [GT Designer2 
Project] in the menu bar to display the 
"Create New GT Designer2 Project" 
dialog box.

2. Set "Project Name" for the new project.

After setting the item, click the   
button. 

Setting example
• Project Name: GOT_Pro1

3. The new project has been created.

After creating the new project, double click 
it in the workspace tree.

4. The GOT project is activated.

For the method for editing GOT projects, 
refer to the following manuals.

• GT Designer2 Version2 Basic 
Operation/Data Transfer Manual 
(For GOT1000 Series)

• GT Designer2 Version2 Screen 
Design Manual (For GOT1000 
Series)

• GT Converter2 Version2 Operating 
Manual

• GT Simulator2 Version2 Operating 
Manual

• GT SoftGOT1000 Version2 
Operating Manual

• GT Works2 Operating Manual 
(MELSOFT iQ Works)

Select

Double click
3.5.1 Creating new projects 3 - 11
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● Copying projects
The following shows the method for copying a created project in the workspace to create a new project.

1. Right click a project name in the 
workspace tree, and select [Add 
Copy] in the shortcut menu to 
display the "Copy Project" dialog 
box.

2. Enter "Project Name" for the copied 
project, and click the  
button.

Setting example
• Project Name: GXW2_Pro2

3. The project has been copied in the 
workspace tree.

● Changing project names
The following shows the method for changing a project name of an existing project.

• Right click a project name in the 
workspace tree, select [Rename] in 
the shortcut menu, and change the 
project name.

● Deleting projects
The following shows the method for deleting a project.
Once a project is deleted, it can not be restored again.

• Right click a project name in the 
workspace tree, and select [Delete] 
in the shortcut menu. The project is 
deleted.

     Select

     Right click

     Right click

     Select

     Right click

     Select
3 - 12 3.5.1 Creating new projects
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3.6 Editing Existing Projects
3.6 Editing Existing Projects
This section explains the method for editing created projects and utilizing them to other workspace.

3.6.1 Editing existing projects

This section explains the method for starting and editing a created project.

The following is an example of starting a programmable controller project.
This operation is also performed to start a motion controller project and a GOT project.

1. Double click a programmable controller 
project in the workspace tree.

2. The programmable controller project is 
activated.

For the method for editing a programmable 
controller project, refer to the following 
manuals.

• GX Works2 Version1 Operating 
Manual (Common)

• GX Works2 Version1 Operating 
Manual (Simple Project)

• GX Works2 Version1 Operating 
Manual (Structured Project)

• GX Works2 Beginner's Manual 
(Simple Project)

• GX Works2 Beginner's Manual 
(Structured Project)

Double click
3.6.1 Editing existing projects 3 - 13
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3.6.2 Utilizing existing projects (import)

This section explains the method for utilizing a created project in other workspace using MELSOFT 
Navigator.

The following operation is an example of utilizing the GX Works2 projects.
This operation is also performed to utilize the MT Developer2 or the GT Designer 2 projects.

● Importing projects
Projects in a workspace created using each engineering software product (GX Works2, MT Developer2, and GT 
Designer2), can be imported to a workspace created using MELSOFT Navigator.

1. Select [File] ⇒ [Import Project] ⇒ [GX 
Works2 Project] in the menu bar to 
display the "Import GX Works2 Project" 
dialog box.

2. Select "Save Folder Path" and 
"Workspace" for the project to be 
utilized.

Setting example
• Save Folder Path  : C:\Documents and 

Settings\Administrator\
My Documents

• Workspace Name : Sample

(To the next page)

Select
3 - 14 3.6.2 Utilizing existing projects (import)



1 

O
V

E
R

VI
EW

2

S
C

R
E

E
N

 C
O

N
FI

G
U

-
R

AT
IO

N

3

C
R

EA
TI

N
G

 W
O

R
K

-
SP

A
C

ES

4

U
S

IN
G

 L
A

B
EL

 L
IN

K-
A

G
E 

FU
N

C
TI

O
N

5

U
S

IN
G

 P
R

O
G

R
A

M
 

JU
M

P
 F

U
N

C
TI

O
N

3.6 Editing Existing Projects
(From the previous page)

3. Select a workspace to display the list of 
registered GX Works2 projects.

Set "Project Name" for the project to be 
utilized, and click the  button.

Setting example
• Project Name: GXW2_Pro3

4. The project has been imported in the 
workspace tree.

● Importing projects
The projects in several workspaces can be organized into one workspace.
For details, refer to the HELP function of MELSOFT Navigator.
3.6.2 Utilizing existing projects (import) 3 - 15
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3.7 Saving Workspaces
This section explains the method for saving the created workspaces.

■ Saving workspaces with the specified name

This section explains the method for saving the open workspace with the specified name.

■ Overwriting workspaces

This section explains the method for saving the open workspace with the same name.

1. Select [File] ⇒ [Save Workspace As] in 
the menu bar to display the "Save 
Workspace As" dialog box.

2. Set "Save Folder Path", "Workspace 
Name", and "Title" for the workspace.

After setting the items, click the  
button to save the project.

Setting example

• Save Folder Path : C:\Documents and 
Settings\
Administrator\
My Documents

• Workspace Name: Sample_Workspace
• Title (option) : Sample data

• Select [File] ⇒ [Save Workspace] ( ) 
in the menu bar to overwrite and save 
the workspace.

Select

Select
3 - 16  
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3.8 Saving Archived Workspaces and Projects
3.8 Saving Archived Workspaces and Projects
This section explains the method for saving the archived workspaces or projects as CAB files.

■ Saving archived workspaces and projects

The following operation is the example of saving an archived workspace.
This operation is also performed to save an archived projects.

● Saving archived files
The archived and saved workspaces or project data are portable.

1. Select a workspace name to be 
archived, and select [File] ⇒ [Save as 
Archived File] in the menu bar to 
display the "Archive and Save" dialog 
box.

2. Set "File Position" and "File name" for 
the archived file.

After setting the items, click the  
button to archive and save the file.

Setting example

• File Position : My Documents
• File name : Sample_CABfile

(To the next page)

Select
3 - 17
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(From the previous page)

3. A CAB file has been created in the 
specified location.
3 - 18  
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3.8 Saving Archived Workspaces and Projects
■ Decompressing archived files

1. Double click the archived file (CAB file).

(When performing the above operation, 
associating the CAB file with a 
decompressing application is necessary.)

2. The file is decompressed in the same 
folder where the archived file is in.

3. Double click "Sample_WS" in the 
decompressed file to open the 
workspace.

Double click

Double click
3 - 19
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● Decompressing files
For decompressing the CAB files, use the application which can recover the folder structure.

• Using the application which can recover the folder 
structure

• Using the application which cannot recover the 
folder structure

● Decompressed files
For the decompressed files, the folder structure in the workspace tree cannot be maintained as before 
decompressing, and the files are decompressed in a project basis.
Be sure to enter the correct save folder path when using each engineering software product to open the project.
• Structure of decompressed file • Workspace tree display
3 - 20  
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3.9 Closing Workspaces
3.9 Closing Workspaces
This section explains the method for closing the open workspace.

1. Select [File] ⇒ [Close Workspace] in 
the menu bar.

2. Click the  button to close the 
workspace.

When the workspace has not been saved, the following message is displayed.
Click the  button to save the workspace.
Click the  button to not save the workspace and close it.

Select
3 - 21
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3.10 Exiting MELSOFT Navigator
This section explains the method for exiting MELSOFT Navigator.

• Select [File] ⇒ [Exit MELSOFT 
Navigator] in the menu bar to exit 
MELSOFT Navigator.

When the workspace is being opened, the following message is displayed.
Click the  button to close the workspace.
Click the  button to stop the operation of exiting MELSOFT Navigator.

Select
3 - 22  
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4 USING LABEL LINKAGE 
FUNCTION

This chapter explains the label linkage function which enables the labels defined in a programmable controller 
project or a motion controller project to utilize in a GOT project.
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4.1 Example of System Configuration
This section explains the method for using the label linkage function in the following system configuration.

Model: Q173HCPU

Project name: MTD2_Pro1

Label setting: No

Model: Q25HCPU

Project name: GXW2_Pro3

Label setting: Yes

Model: GOT1000

Project name: GOT_Pro1

MELSECNET/H

Model: Q06UDHCPU

Project name: GXW2_Pro1

Label setting: No
4 - 2  
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4.2 Selecting Reference Programs
4.2 Selecting Reference Programs
This section explains the method for utilizing the labels, which are defined in a programmable controller 
project or a motion controller project, in a GOT project.

1. Double click a GOT project in the 
workspace tree.

2. The "Select Reference Project" dialog 
box is displayed after the GOT project 
has been activated.

3. Select a reference project.
After selecting the item, click the  
button.

Setting example

• Project Name: GXW2_Pro3

(To the next page)

Double click
4 - 3



4  USING LABEL LINKAGE FUNCTION
iQ Works
(From the previous page)

4. When the  button is clicked, 
the labels are checked, and the GT 
Designer2 programming screen is 
displayed.

● Saving archived files
When GOT projects, which use the label linkage function, are archived and saved, archive and save the project 
data that has been selected in the procedure 3.
4 - 4  
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4.3 Specifying Labels
4.3 Specifying Labels
Label names of the programmable controller project or the motion controller project can be specified when 
setting devices for the graphics created using GOT.
For creating graphics using GOT, refer to the following manual.

 • GT Designer2 Version2 Screen Design Manual (For GOT 1000 Series)

1. Double click the created graphic to 
display the setting screen.

2. Click the  button to display the 
"Select CH No." dialog box.

3. After the "Select CH No." dialog box is 
displayed, click the 

 button to 
display the "Label List" dialog box.

4. Select a label to be used from the 
"Label List" dialog box, and click the 

 button.

5. After the setting has been completed, 
the label name is displayed.

Double click
4 - 5
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● Setting screen
In the procedure 2, if a device has been entered in the "Device" field, delete the device first, and then click the  
button.
If the  button is clicked before deleting the device, the "Select CH No." dialog box is not displayed.
For displaying the "Select CH No." dialog box always, refer to the following manual.

 • GT Designer2 Version2 Screen Design Manual (For GOT 1000 Series)
4 - 6  
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4.4 Updating Labels
4.4 Updating Labels
This section explains the method for updating the labels used in a GOT project when the labels of the 
programmable controller project or the motion controller project are changed and saved.

• Select [Tools] ⇒ [Label Update Check] in 
the menu bar to update the labels.

● Updating labels
For the GOT project in which labels are specified, the Label Update Check function is performed automatically 
when the GOT project is activated.
4 - 7
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5 USING PROGRAM JUMP 
FUNCTION

This chapter explains the program jump function which can start the motion SFC programs/servo programs 
that are linked with the motion controller programs, using the SFCS instructions/SVST instructions of the 
ladder programs in the multiple CPU system.
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5.1 Example of System Configuration
This section explains the method for using the program jump function in the following system configuration.

■ Motion controller start-up programs

The followings are the instructions which start the motion controller programs used in the ladder 
programs.
• SFCS instruction (Motion SFC program start-up)
• SVST instruction (Servo program start-up)

For details, refer to the following manuals.

• Q173HCPU/Q172HCPU Motion Controller (SV13/SV22) Programming Manual (Motion SFC)

• Q173DCPU/Q172DCPU Motion Controller (SV13/SV22) Programming Manual (Motion SFC)

This section explains the program jump function using the following ladder program.

Motion Controller (CPU No.2)

QCPU (CPU No.1) 
5 - 2  
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5.2 Folder Properties
5.2 Folder Properties
This section explains the method for setting the property of a folder in the workspace tree.
If the properties of folders have not been set, the program jump function cannot be used.

1. Right click a folder in the workspace 
tree and select [Properties] in the 
shortcut menu to display the "Folder 
Properties" dialog box.

2. Check the "Show CPU number." item, 
and then set "Number of CPUs" to be 
assigned with the project.

After setting the items, click the  
button.

Setting example

• Number of CPUs: 2

3. "[CPU No.1] Empty" and "[CPU No.2] 
Empty" are created in the folder.

(To the next page)

     Right click

    Select
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4. Select a project in the folder in the 
workspace tree, and drag and drop it 
onto "[CPU No.1] Empty".

5. As same as the procedure 4, select 
another project in the folder in the 
workspace, and drag and drop it onto 
the "[CPU No.2] Empty".

● Project assignments
When assigning a project to "[CPU No. n] Empty", the assignment can be performed if the "[CPU No. n] Empty" 
and the project are in the same folder.

● Project assignment errors
When assigning a project to "[CPU No. n] Empty", the error check function is performed.
If there is a project assignment error, the warning icon and the error message are displayed as shown below.

However, the error check function is not performed between multiple CPUs.

Drag & drop
5 - 4  
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5.3 Program Jump Function
5.3 Program Jump Function
The following explains the method for using the program jump function with the SFCS instruction.
Follow the same procedure shown below when using the program jump function with the SVST instruction.

1. Double click a programmable controller 
project in the workspace tree.

2. The programmable controller project is 
activated.

3. Select "Program_Pool" ⇒ "MAIN" ⇒  
"Program [Ladder]" in the Project 
window to display the ladder program 
window.

(To the next page)

Double click

     Select

     Ladder program 

     window is displayed
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(From the previous page) 

4. Right click the SFCS instruction on the 
ladder program window and select 
[Find]⇒ [Program Jump] in the shortcut 
menu.

5. The motion controller project is 
activated and the target motion SFC 
program is displayed.

Right click

Select
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